Increase in the number of Liveness service errors
Incident Report for Caf
Resolved
We continued to investigate the problem and restricted the occurrences to iOS devices that use WebView with SFSafariViewController, but without a known pattern of behavior. In addition to several reports of similar problems on various technology forums, we were able to simulate the problem in contexts that did not involve our SDKs, which indicates that it is a generalized inconsistency in this type of integration that is not directly related to Caf.

As a definitive solution to the problem, we recommend that customers who implement SFSafariViewController in their native applications migrate their implementation to WKWebView. More details can be found in our documentation at https://docs.caf.io/home/quick-start-guides/onboardings-integration#ios. The Caf team is available for any questions and will provide the necessary support for the correct implementation of WKWebView.
Posted Jul 23, 2024 - 17:37 UTC
Identified
We have identified the problem is related to managing access to the device's camera and is restricted to Web SDK integrations that use specific WebView mechanisms. Our team is still working on the case in search of possible solutions to automate the solution to the problem.
Posted Jul 19, 2024 - 18:31 UTC
Investigating
We have identified an increase in the number of errors in the service, and we are currently analyzing the problem.
Posted Jul 18, 2024 - 18:36 UTC
This incident affected: SDKs (Passive Face Liveness) and Services (Face Liveness).