Major outage of global document verification services

Incident Report for Caf

Resolved

This incident has been resolved and services are operational again.
Posted Mar 12, 2026 - 17:43 UTC

Investigating

We are experiencing a high error rate in services related to global document verification.
Posted Mar 12, 2026 - 14:40 UTC
This incident affected: Services (Global Document Detector, Global Doc Reader).